• Dear forum visitor,

    It looks as though you have not registered for a forum account, or are not signed in. In order to participate in current discussions or create new threads, you will need to register for a forum account by clicking on the link below.

    Click here to register for a forum account!

    If you already have a forum account, you can simply click on the 'Log in' button at the top right of your forum screen.

    Your Elvenar Team

Discussion A Gateway into the Past - Discussion

muffy.

Chef - Scroll-Keeper - Chandelier Swinger - EAA
I TOTALLY LOVE THIS EVENT !!!!
It actually has a thought process ~

Not so much .. “if your lucky” is involved …thank goodness, my luck isn’t that great .. if it wasn’t for bad luck I’d have no luck at all…lol

I’d say this event gets better reviews then any of the others … so far .

Total Fan !!!!
 

Tauriel Dragonwood

Sir Neckless
I hopped over to the Wiki to see what was posted there re this event.
They say, "Collect the following 7 buildings to complete the Dwarven Citadel:
Memorial of the Savior, Golden Wish, Moon Vendor, Gaming Lounge,
Gates of Dawn, Caves of Dusk, and the Temple of Sun and Moon."

But the picture only shows 6 buildings, see below. So is it 6 or 7 buildings are needed to collect.
Dwarven Citadel Buildings.jpg
 

Tauriel Dragonwood

Sir Neckless
Thank you! :)
You need to be logged into a Google account to see TomatoeHu's page. I can't view the page because I don't have this type of account. Platinum Leaf's website has the quests for the Beta version which may be a wee bit different for the live worlds. By the way, love your signature page. It's quite beautiful. Did our creative forum artist, Sir Squirrel, make that for you?
 

Tauriel Dragonwood

Sir Neckless
7x6
Thank you so much. Why doesn't Elvenar's Wiki have this info? Many of us look to the Wiki for advice, especially sizes of buildings when they're upgraded. Some of our Elvenar players should be working for InnoGames, inputting this info into Elvenar's Wiki. To keep players interested in the franchise, EA Games hired some of the players who create amazing homes for the Sims.
 

crackie

Chef, Scroll-Keeper, Buddy's #1 Fan
The board having tactical value is a giant red herring! So big you could slap someone around a bit with it!
I have asked a Swede what is Swedish about Swedish Fish and he said it is made by a Swedish company, which I was not expecting. Last week, I walked by the Scandanavian House in NYC and found these in their window front...authentic Swedish Fish? Can't tell what they look like inside, but the muted packaging already suggests they might look less radioactive.
real swedish fish.jpg

The real monsters are the bossy people to the right of the warehouse floor game board, but even they can be handled with a judicious yeeting into the bottomless pit that's a offscreen further to the right.
I feel like Thalita is using non-verbal communications to collude with them to scam me of all my coins. I don’t trust any of them. Also, are they all her brothers? :oops:
Incorrect. You need to be logged into a Google account to make a copy. Anyone can see and print the sheet, you just need an account to be able to make your own copy and use it to track progress on quests.
@samidodamage is giving tech advice. I'm so proud of you! *tear*
 

SoulsSilhouette

Buddy Fan Club member
@muffy. There is still a great deal of random built into this event. Just as much if not more than the others. It isn't horrible. I just have no real hope of getting the set in any of my cities, and I have one in each world. I won't place half sets, unless its pieces of the moonstone library because they are great markers for the end of streets.
 

SlyLady

New Member
Anyone else having trouble with the game board? I've had several weird glitches. When I collected my email bonus coins, the game board was entirely blank and displayed no trades, even though there actually were both present previously. When I tried to access the board again, it showed what I expected - game tokens and trades. I was able to make merges - but the merged pieces never disappeared; just stayed on the board like ghost pieces. I could pick them up & move them around, even lay them on top of other pieces, but not merge them. Sometimes, the pieces changed into other pieces, randomly upgrading and even downgrading themselves.

Just now, I tried to dump a trade I did not want and it refused to respond to my request. I reloaded the board and it did the same thing. I then tried to get game pieces out of the cups and it would not respond at all. At least the attempt to dump a trade resulted in the little red can turning grey. There was no response to clicking on the cups.

These experiences were on different browsers and even different player accounts. I played this in beta so it seems unlikely to be user error. Anyone else seen the game board behaving oddly?
 

Kadhrin

Active Member
Disliking this one rather intensely and have given up hopes of getting the full set of buildings.
The randomness of what you get for your chips means that the chips-per-gem is actually highly variable, and what looks like a good deal at the outset can be very, very expensive if you don't have the required goodies.
 

Tauriel Dragonwood

Sir Neckless
Incorrect. You need to be logged into a Google account to make a copy. Anyone can see and print the sheet, you just need an account to be able to make your own copy and use it to track progress on quests.
That's what I said. You need to have a Google Account, which I don't have, to view the page.
 
Top