• Dear forum visitor,

    It looks as though you have not registered for a forum account, or are not signed in. In order to participate in current discussions or create new threads, you will need to register for a forum account by clicking on the link below.

    Click here to register for a forum account!

    If you already have a forum account, you can simply click on the 'Log in' button at the top right of your forum screen.

    Your Elvenar Team

Buildings won't open.

Went to check trader and my trader won't open, collected goods from day farm and night farm, collected troops, but none of the buildings will open to let me begin new productions.

I have restarted Fire Fox, twice, Using Fire Fox version 59.0.1 on a Windows 10 Pro OS.
 

Azkaban

Guest
Likewise, but after I reload, everything works. Doesn't seem to matter whether I'm using Firefox or Chrome, I still have the glitch.
 

My Shadow

Well-Known Member
Same here, seems I always have to refresh in order to open up buildings and start productions. I'm also thinking this started happening about the same time as the current event.
 

Azkaban

Guest
I've had the issue for some time, and on different servers, so it's not localized to the US server. :(
 

Nytcretur

New Member
Even when I refresh I can't get into most of my buildings. I can collect and spend my KP but can't make anything. just started on sunday the 13th of may.
 

No Sane Person

Guest
Even when I refresh I can't get into most of my buildings. I can collect and spend my KP but can't make anything. just started on sunday the 13th of may.
Close your browser, then reopen it. That works for me when refreshing doesn't.
 

Calenmir

Well-Known Member
Same here - cleared cache for each city and that worked, but have neither time, desire or patience to keep doing that. Refreshing is not helping. Closing and opening browser not working for me either. Can this be looked into urgently given we're in the middle of an FA?
 

Nytcretur

New Member
How do we clear the cache for each city? I made a new city to see if I could do anything and its bugged in that one too.
 

Calenmir

Well-Known Member
Clearing cache, for me, is done in settings. I'm using Edge. I open the browser and then the city, then clear the cache then refresh the city. Then go to next city (whether you sign out and open new city or just open a new browser tab) clear the cache and refresh. That's the only thing working for me. Good luck.
 
Similar issue. I can not access Trader menu, or any building other than Armory or Ancient Wonders on Microsoft Edge.
I can collect from them, but cannot open them.

From Android app, this problem is non-existent.

*Update: Just tried to access from Firefox Nightly which I haven't been able to get the game to load on since last year and it loaded up fine and everything works there. I don't know what you did to break Edge, but leave it like this. Thank you. ;)
 
Edge isn't the only one affected; Chrome and Firefox are as well.
Yeah, it seems like it is a weird thing going on. My Firefox Nightly is fine, for whatever reason that it works now, I can again stop using Edge for anything. Hopefully whatever they do to fix it won't go back to giving me that strange Flash error that prevented the game from loading in Firefox for the longest time.
 

Lord Draconian

Well-Known Member
Chrome, Firefox and Maxthon have been fine for me but have had to clear the cache on Edge every time I've played all day. No amount of refreshing helps.
Everything collects fine and then every building is just dead. :(
 

WysteriaMystique

New Member
Even when I refresh I can't get into most of my buildings. I can collect and spend my KP but can't make anything. just started on sunday the 13th of may.
Same here, May 11, after I did the microsoft update. I switched from Edge browser to Google Chrome and everything is working fine.