• Dear forum visitor,

    It looks as though you have not registered for a forum account, or are not signed in. In order to participate in current discussions or create new threads, you will need to register for a forum account by clicking on the link below.

    Click here to register for a forum account!

    If you already have a forum account, you can simply click on the 'Log in' button at the top right of your forum screen.

    Your Elvenar Team

Confirmed CH16 troops booster buildings gives 0% benefits

dravigas

New Member
CH16 troops booster buildings(Dwarven Armorer, etc..) gives 0% benefits. Chapters 15 and below seems correct.
Is it intended nerf as it's popular those days?
is it actual Bug?
Attached pics Mage units multiplier - 100% ;Dwarven Armorer health multiplier -100%

Untitled5.jpg

Untitled6.jpg
 

KarlD

Well-Known Member
It's a bit scary since ElvenArchitect shows the benefit as zero also from which I infer that the problem has been there since Beta when they were collecting building data. Maybe it's not a bug, but a feature. I'm holding off on entering Chapter 16 until there's an answer. There's really nothing in Chapter 16 that I especially want. I'd rather upgrade my city in Chapter 15 until I simply have nowhere else to go.
 

PaNonymeB

Well-Known Member
The upgrade tab of my Ch. 15 DA says :
  • Culture : 700 --> 850
  • Troops health : 150% --> 100%
  • Cost : 6 RR spells.
 
Last edited:

Enevhar Aldarion

Well-Known Member
It is probably a bug specifically tied to being in chapter 16, rather than a general bug that was introduced with the update. I am working on the first quests of chapter 16, but have not completed the first research yet, so I am still counted by the game as being in chapter 15 and my boost buildings are working correctly.

Someone already in chapter 16 needs to craft a new one from the MA and see if a chapter 16 version of the building has the same bug.
 

MinMax Gamer

Well-Known Member
Can confirm for ELR as well. Chapter 15 shows 150%, and freshly crafted chapter 16 shows 100%. I mean, seriously?!
 

Enevhar Aldarion

Well-Known Member
Can confirm for ELR as well. Chapter 15 shows 150%, and freshly crafted chapter 16 shows 100%. I mean, seriously?!
If no one complained at all over the past couple of week on Beta, though, is this just a Live bug? Or is it now the same with these buildings over on Beta as of the Live update yesterday?
 

Enevhar Aldarion

Well-Known Member

T6583

Well-Known Member
Question does this bug only effect the buildings if they're upraded to or at Ch. 16 or does it occur when the player enters Ch. 16 (finishes the Senate research)? I have a bunch of Ch. 15 temp military bonuses that I don't plan to upgrade at all some of which are already out for this week's tourney. I should be finishing the research tomorrow morning for the Senate building. I'm wondering if I should hold off on doing so and what to tell my FS. Right now I've alerted them to the bug. But clearly I myself don't fully understand the trigger / extent of it. Does it affect AW troop bonuses as well?
 

MinMax Gamer

Well-Known Member
Question does this bug only effect the buildings if they're upraded to or at Ch. 16 or does it occur when the player enters Ch. 16 (finishes the Senate research)? I have a bunch of Ch. 15 temp military bonuses that I don't plan to upgrade at all some of which are already out for this week's tourney. I should be finishing the research tomorrow morning for the Senate building. I'm wondering if I should hold off on doing so and what to tell my FS. Right now I've alerted them to the bug. But clearly I myself don't fully understand the trigger / extent of it. Does it affect AW troop bonuses as well?
I am in chapter 16, and chapter 15 boosters in my inventory are fine. Only chapter 16 ones are borked.
 

Xelenia

Senior Forum Moderator
Elvenar Team
@Xelenia
Can you help find anything out on this? I'd sure hate for every fighter in Ch16 to start sending in support tickets if there's a better way to get it handled (or not if this is expected behavior).
I will move this to the bug section. It should not be the norm, I will investigate and hopefully push it up the pipeline.

I will appreciate additional pictures from live players if possible.

Thank you for the ping!
 

KarlD

Well-Known Member
You probably don't need pics from live players cuz it appears 100% reproducible. I'm still in Chapter 15 and if I go to the upgrade tab of my military boost culture buildings they all show that the boost goes away if I were to upgrade. I'm not inclined to waste 4 RR spells to upgrade and possibly lose the boost of my buildings so I'm hoping developers will take a look soon.
 

Enevhar Aldarion

Well-Known Member
So, everyone is showing pics of the buildings either in inventory or in crafting or looking at the number in the Upgrade tab, which I can look at too because I am in chapter 15 for a few more days. But has anyone actually put one out and verified that the bonus does not exist at all and is not just a visual bug in the Info window?
 

Enevhar Aldarion

Well-Known Member
I looked at the Beta thread and the person who started it has a pic of the info screen for a chapter 16 DA that was placed out. But no one has shown a pic of the troop info screen in the Barracks, etc to see if the bonus is missing there or just the info is missing from the building description.

@MinMax Gamer since you have a Beta account, can you contact the player who started that Bug thread and ask him if he checked his actual troop health for the boost? Unfortunately, I think he started the thread over five days ago, so it may already be expired and he won't be able to look now.
 

Kekune

Well-Known Member
Can confirm that my upgrade tabs also show this. I don't have a ch16 building to place, and like KarlD and MinMax, wouldn't particularly want to sacrifice one to find out more.