1. Dear forum visitor,

    It looks as though you have not registered for a forum account, or are not signed in. In order to participate in current discussions or create new threads, you will need to register for a forum account by clicking on the link below.

    Click here to register for a forum account!

    If you already have a forum account, you can simply click on the 'Log in' button at the top right of your forum screen.

    Your Elvenar Team
    Dismiss Notice

Open KP Reset When Collecting Coins

Discussion in 'Found a bug?' started by NightshadeCS, Jun 7, 2018.

  1. NightshadeCS

    NightshadeCS Active Member

    Joined:
    Nov 6, 2016
    The counter on my KP bar resets when I collect coins from a residence. It also seems to reset when performing other tasks, but I have no others available to currently test this issue.

    Game version: v1.55.5-(b032bbac9) (2018-06-05 12:59)
    Game world: Arendyll
    Browser + version: Chrome Version 66.0.3359.181 (Official Build) (64-bit)
    Flash Player version: __
    Operating System: Windows 10
    Screen resolution: 1920 x 1080
    Account name: NightshadeCS
    Humans or Elves: Elves

    Reproducibility: 5/5 (1/5 = happened once; 2/5 = happens randomly; 3/5 = happens sometimes; 4/5 = happens often, but not always; 5/5 = happens always)

    Quest title: __ (if applicable)

    Current situation:
    KP Timer Bar resets to 59:59 (after displaying -xxx (some number of seconds) and then 1:00 h, then going to 59:59 and counting down). I currently have 7 KP in bar and Inspiring Meditation active.

    Expected situation:
    Bar unaffected by coin collection.

    Reproduction Steps
    1.
    __
    2. __
    3. __
    4. __
    5. __

    Add more steps if needed. Include only ONE action for each step!

    Screenshots of the bug:
    (add as many screenshots as you need)
     

    Attached Files:

    Last edited: Jun 7, 2018
  2. NightshadeCS

    NightshadeCS Active Member

    Joined:
    Nov 6, 2016
    Correction, this happens whenever I perform any collection currently (collected supplies from Endless Excavation, goods from winter set buildings, coins from summer set buildings).
     
    derpityderpderp likes this.
  3. Xelenia

    Xelenia
    Senior Forum Moderator
    Elvenar Team

    Joined:
    Oct 28, 2017
    Thank you everyone for the information on this, I cannot replicate the problem but clearly, it is there. I will see if there is a JIRA on this, and if not, will give you both a ping once a new update is release to see if it is still occurring.

    P.S can you both see if you can replicate it once more and add it under the list of reproduction steps? Perhaps there is one specific problem that triggers it...I suspect it may have something to do with the other ongoing kp problem.

    Xelenia
     
    shimmerfly likes this.
  4. derpityderpderp

    derpityderpderp New Member

    Joined:
    Aug 12, 2017
    [​IMG] [​IMG]
    Ok. So the pic on the left is before i collected from a res. And the pic on the right is taken after collecting (actually, i had to collect twice because i hit the wrong screenshot buttons the first time). But you can see that the KP timer has reset itself. I can't collect and take screenshots as fast as the original poster but i get the same intermediate timer display (-1000s or some other absurdity).

    EDIT:
    After taking those screenshots i let my timer run out a bit and now the problem seems to have subsided. My KP timer now reads "42:15" and the problem does not occur when i collect coins or do other actions.
    Maybe it only happens within the first 5m-10m after the clock resets naturally? I'll try to catch it on the next cycle and see if it happens again.

    EDIT 2:
    So i caught the next cycle and the issue did not happen again. I collected a couple minutes before the 00:00 mark and i collected a couple times after (at about 59:xx and 56:xx) and the problem didn't appear. I tried various actions and wasn't able to reproduce it. But i'll try again on the next cycle if i'm on.
     
    Last edited: Jun 8, 2018
    Xelenia likes this.
  5. NightshadeCS

    NightshadeCS Active Member

    Joined:
    Nov 6, 2016
    Yes, I have not had the problem again since that one stretch of time while I was collecting. I did reload the game once in the midst of that, and it still did it, but once I logged on again later in the day, it did not happen again. If it happens again, I will update.
     
    Xelenia likes this.
  6. NightshadeCS

    NightshadeCS Active Member

    Joined:
    Nov 6, 2016
    I have encountered this problem again. Just now, my KP bar was up to 19 filled and it started resetting when I made any type of collection. I spent one KP to see if that would change things. It did not. The timer even resets when I accept trades.
     
  7. NightshadeCS

    NightshadeCS Active Member

    Joined:
    Nov 6, 2016
    I don't know if this has anything to do with it, but when I logged on, I had 18 KP in my bar, but my Inspiring Meditation had worn off, so there were only 10 slots shown. I cast a new inspiring meditation, and in very few minutes, I gained one KP due to the timer counting down. That seems to be the point when the timer started resetting after collections.
     
  8. Aramina

    Aramina Well-Known Member

    Joined:
    Nov 29, 2016
  9. edeba

    edeba Well-Known Member

    Joined:
    Aug 13, 2016
    A problem that I've had and other people in my forum have had is that the game has refused to let you use the last kp, so you have say 26 after doing the tournament and you get repeated reloads when you try to use them all at once, and you have to use them 1 at a time, and the reload message comes back for the last one. Twice I've watched my counter go to zero and add one, and then not be able to use it.

    Today something different happened. My counter went to zero, and it gave me 16 kp, and then I did another province in the tournament and I didn't go to 21, I went to 20.

    Now I am afraid to collect from the tournament over the kp limit from collection for the timer because I only got 4kp when I was supposed to get 5.

    I think the problem is around the timer adding a KP because I had the reload problem last time around the timer adding a kp.
     
  10. Bruce the Fierce

    Bruce the Fierce Member

    Joined:
    Dec 23, 2015
    It also happens when you log into the game.
     
  11. Bruce the Fierce

    Bruce the Fierce Member

    Joined:
    Dec 23, 2015
    The mobile app is showing the problem in a different way. In the mobile app, the timer appears to be stuck at 00 seconds.
     
  12. NightshadeCS

    NightshadeCS Active Member

    Joined:
    Nov 6, 2016
    Problem occurred again this morning. I logged on and had 9 KP in my bar, IM had expired. I cast IM, increasing bar slots to 20, 9 still filled, 7 minutes until I would gain one. Performed a collection just fine. Then gained the one extra KP when the timer ran down, bringing me to 10 (IM still active, of course). Any collection (workshop, residence, manu, etc.) now results in a timer reset.
     
  13. derpityderpderp

    derpityderpderp New Member

    Joined:
    Aug 12, 2017
    Problem is occurring again. This time i noticed it because i kept getting the 'internal error' popup every time i tried donating to an AW, and after the 4th or 5th error i noticed that the KP timer was resetting after each error reload. I was able to donate 1kp at a time to the AW and get 19 of the 20 owed but now i cant get the last KP into the AW.
    I posted this in"Server Error when Using KP" thread because the two threads seem to be linked.

    EDIT:
    After posting this i noticed that, indeed, the two problems are linked. When i went back to my city i noticed that not only could i not donate to the AW without getting the 'internal error' popup, but that every time i did any action (collecting coin, etc..) the KP timer was resetting.
    Finally i bought 1kp (yes, the kp timer reset again while doing this) and then was able to donate to the AW without the error. But i'm still getting the KP timer reset every time i do an action, i just don't get the "internal error" pop up.

    Should also mention that i'm using Inspiring Meditation also, like many people who are having this issue.
     
    Last edited: Jun 20, 2018
  14. derpityderpderp

    derpityderpderp New Member

    Joined:
    Aug 12, 2017
    OK. Here's how it happened (i paid attention this time).
    I had about 2min left on the KP clock. I then cast Inspiring Meditation. Then i did a tourny province (not sure if its relevant). While completing the tourny province the KP clock had completed its cycle.
    I then went back to my city and, with about 59min left on the KP clock I collected supplies. When i did that the KP timer reset to -103s (or something absurd like that) and 1KP was subtracted then given back when the KP timer reset to 59:59.
    I let the timer run down to 52min while creating this post, then i went back to my city and tried to start a supply production cycle. When i selected a 15min production the KP timer reset to -537s, then took 1KP away, then reset to 59:59 and gave the 1KP back and started its countdown again. While writing that sentence i went back to my city and the Chrome glitch had frozen my city so i reloaded the game. When the game reloaded i had about 58min on the KP clock. I selected another workshop to begin another supply production. When i selected a 15min production cycle the KP timer reset again.
    I could keep doing this again and again but i think you get the point. The issue has to do with Inspiring Meditation and the KP timer.
    If support would like to contact me and tell me how to send them logs i'd be happy to do that if it would help resolve this seriously annoying issue.

    ADDENDUM:
    While completing this post the game has frozen again (Chrome glitch) in the other tab with "59:XX" on the KP clock. When i refreshed the page (or reloaded the game, however you want to put it) my city reloaded with 59:59 left on the KP clock. Minus the possibility of time travel there's no way that reloading the game took negative time. The KP timer should have kept running even if the game was frozen. When i reloaded the game the KP timer should have been down to 57min at least (because it should have kept running after the game froze while i was completing the post, and kept running while i was reloading the game). And of course, since the timer hasn't run down far enough the KP timer keeps resetting whenever i do an action.
    The only remedy (and its not even an actual remedy) i've found is do just stop doing stuff and let the KP timer run down to below 50min. Once its out of that 59:59 - 49ish range the issue seems to cease.

    ADDENDUM 2:
    The above range isn't correct. I let the clock run down to 48:XX and the KP timer still reset when i collected coins. I really have no clue how to stop it. IDK what actions/inactions actually stop the glitch from occurring. But its incredibly frustrating. Wish i knew that the devs were taking some kind of action.

    ADDENDUM 3 (last one):
    Member of my FS suggested that i try donating 1kp to an AW. I chose one of her AWs (Neeldes) and donated 1kp. The KP timer reset when i did that. And when i came back to my city i collected coins and the KP timer reset again. So it seemed like that recommendation didn't work. BUT, i let the clock run down to 57:XX and when i collected this time the issue ceased.
    So something about donating to an AW, then letting the timer reset upon collection, then collecting once more a couple minutes after that and the issue ceased.
    But for all i know it has nothing to do with the AW. I also changed the TV channel, sneezed, made some chili, and went to the bathroom. Could have been any one of those actions that stopped the glitch.
     
    Last edited: Jun 27, 2018
    shimmerfly likes this.

Top