• Dear forum visitor,

    It looks as though you have not registered for a forum account, or are not signed in. In order to participate in current discussions or create new threads, you will need to register for a forum account by clicking on the link below.

    Click here to register for a forum account!

    If you already have a forum account, you can simply click on the 'Log in' button at the top right of your forum screen.

    Your Elvenar Team

Research Screen not loading

Teppic

New Member
I can't open the research screen in either of my cities. Others reporting similar problems. The loading screen starts then the game freezes
 
Same here! Tried reloading game, restarting browser, changing browsers, restart computer...
Also having issues with World Map screen not loading!

Been having this problem for about 1 hr! Super irritating! :(
 
Last edited:

Neamhain

New Member
Glad to hear I'm not the only one with an issue. I play on US 4 server and Research screen is doing the same thing.
 

Yogi Dave

Active Member
Sigh, sorry to say I'm in the same boat.

I try going to research, the city goes black and white. Progress bar quickly goes full then resets and only goes about 1/8 over. Chat still works and pressing L still brings up the logout dialog which works.

Going to the world map is different. The user window part of the browser goes a deep blue and that is the end. Have to close the tab.

Happens the same in two worlds. I was on before the update, but hadn't gone to any other window when I was kicked off for the update. So, I don't know if the problem started before then. A fellow in my FS was on when the update occurred and was kicked out. After login, everything still works for her.
 

Yogi Dave

Active Member
Glad to see a news report in my city from Inno saying they know of the problem and are working on it. Got a similar response to the ticket I put in a few minutes ago.

Also, I used mobile to at least put my kp into a tech. Hope the rest of you can do the same
 

ToadTheBold

New Member
I have the same issue. No access to the World or research screens on US5, US6, or US7. I have tried on Firefox and IE (latest version of each).